Murder mystery map bug

Affected Service (Game name, hub, or global):
Murder mystery asia (don’t know map name)

What is the bug?
Hi people or hive staff what the DUCK is murder mystery going through. today was a normal day until i decided to play on the hive murder mystery. got the nether glitch thingy (the screen where you stuck saying generating world) after a couple minutes it finally worked and i was in uh i really don’t know how to say this but i was under the MAP ye… not a single command worked it was like your plugin or mod things that makes the server function can’t see me nothing was working even when the game ended it didn’t put me in a new game or when i tried return to hub item you guessed it! didn’t work. please fix this thanks - ItzpopYT

Device(s) & Version

Screenshots and/or video:
here’s some attachments (i had a video too but it wasn’t going in)


Thanks for taking the time to submit this bug report. This is being caused by latency and device limitations.

Hope you have a wonderful day! :blobheart: