A Controller Bug pertaining to the new hive ui update

The Hive Hub, and in the Asia Region

The bug is(well for my controller) every time i play a game when I’m in the hub is when i hit right click on the compass with all the list of games, e.g. the order of the games when you right click the compass are skywars, treasure wars,
and etc. Most of the time when i hit right click skywars is always getting selected like with the green outline since its on the very first of the list, but when i right click the compass in the hub, treasure wars, the second part of the list gets selected in the video i sent here in this post.

I play on an IOS device and I play on the latest version of mcpe.(which is, as i am writing this, 1.17.11)

Here are some clips of me with the bug(well for me i guess but when i test it it only happens on the hive)

Hey there :wave:

Thanks for submitting a bug report!

We’re looking into this issue - if anybody else has experienced it, can you please provide the following information:

  • Your GUI scale (found in settings)
  • Model of your device (iPhone 7, Samsung Galaxy S8 etc.)
  • Minecraft version
  • If you are using any resource packs


This happens to me as well when I use a controller on my iphone but doesn’t do the same on my galaxy phone (Skywars is always highlighted with green first) I don’t see it as a big deal but it certainly happens to me.

GUI Scale: 0
Phone Model: iPhone XS
Version: 1.17.11
Packs: No Packs

iPhone Screenshot:

I also experience this issue

GUI Scale: 0
Phone Model: Samsung Galaxy S8
Minecraft Version: Latest (1.17.11 I believe)
Packs: I use packs (If names are needed lmk)

I use a PS4 controller

I have also started getting pretty high delay, but this might just be an issue on my end.

Double post. but when going into the new ui it is at the top (Like if you’re going into a skywars game)

But everything else is still on the second one down.

GUI Scale: 0
I play in Nintendo Switch
Minecraft Version: 1.17.11
No packs
I love TW (I’ve played 25 hundred games) every time I go into the shop it starts me on armor and makes using the shop 47 times harder. I’m used to spamming the button to buy a lot of blocks but now doing that buys wood : /

Nintendo switch
GUI: 0
Edit: I set my gui to -1 and it fixed it

Same here thats why i thought this was a bug on my device

GUI Scale: 0
Device: iPhone 7
Minecraft Version: 1.17.11
Resource Packs: None

I also tried that if u lower the gui scale in mc settings the bug gets fixed but its too small for me to see due to me having a small phone which is iphone 7

That’s not a small phone compared to the iPhone 4

We’ve pushed a fix for this out. Please let us know if it continues to happen after this message. It may require a full restart of your Minecraft client (closing the app and re-opening).


Works great thanks!

This issue has been fixed :slight_smile: