Unable to Join the Hive

I’m on windows 10 edition, and every time i try to join it says connecting to external server. Then, after a few minutes, it says connection timed out, unable to connect to world. The same thing happens when I want to join mineplex, but it lets me join any other server. Please Help

Try restarting Minecraft/your device, if that doesn’t work, log-out and back into your Xbox account :crazy_face:

Additionally, welcome to the forums!

3 Likes

And if restarting your device or minecraft doesn’t work, try checking your wifi connection to see if it’s down, slow, or you’re not connected.

And welcome to the forums @Masterc5413 !

1 Like

I did this but it doesn’t work still

I tried this, my WiFi is good and still doesn’t work :confused:

What is your ping to the Hive?

My ping is mostly between 60-80

Make sure you do not have a VPN activated. This will block your entry to the hive.

2 Likes

I don’t use vpns, is there any other way?

Unfortunately it does sound like you’re having connection issues :frowning_face:

Have you tried using a different skin? Some skins might prevent you from joining our server

5 Likes

I tried multiple skins including Steve and it still doesn’t let me in

What update are you on? That is a key thing that you must not forget! Remember to update to the latest version (not beta) and if you are on beta, uninstall the game and download the non-beta release.

2 Likes

Some beta versions are supported, others not apparently.
Here is a screenshot from their website

(but usually when you try to connect with an unsupported version, it either tells you, that your version isn’t supported or you are stuck at the loading resources screen, which isn’t the case here)

2 Likes

I’m currently on v 1.16.40 on win 10

Do you have parental restrictions?

No, I don’t have parental restrictions.

Try uninstalling it and reinstalling it and see what happens.

make sure to back up your worlds if you want to keep them.

8 Likes

Here are some Tips :-1:

  1. Try Checking your connection (Disable any vpn /proxy Connection)

  2. Try Restarting Minecraft

  3. Try reinstalling Minecraft (Best Solution So far) {Back up your worlds first}

  4. Try Checking your version, Just as what @BaumV1nn1 Said

Well that’s it hope it helps you

1 Like

Unfortunately I have tried and still nothing, sad times :frowning: